
Head Swaps in Photoshop 
 

There are limitations to what can be done when swapping heads in Photoshop. 

Ideally, you want the donor head (and the body to which it is attached) to be in the 

same or similar lighting and position. If they are on the same background as well, 

life is good. Generally, a head swap involves just one person, though head 

swapping between brides and grooms can be entertaining, if not especially artistic.  
 

 

1.  Start by opening the recipient file. Raw files are best; PSD’s are good too 

 

2. Zoom in on the head that is to be swapped. You’ll usually want the whole 

head, all the hair, and a bit of the shoulders and torso showing 

 

3. In Bridge, navigate to the folder containing the image with the donor head 

 

4.  Place the image with the donor head into the recipient image 

 

If the donor image is a JPG or TIF rather than a Raw or DNG file, it is a good idea 

to do a little prep before placing it. With a JPG or TIF file, right-click on it in 

Bridge and select “Open in Camera Raw.” Once it is open in Camera Raw, make a 

tiny change; one point in any direction with the Color Temp is all you need. This is 

to attach an XMP file to the image so that when you place it, Photoshop will funnel 

it through Camera Raw. Having Photoshop place the image via Camera Raw will 

allow you much more precise control when you start matching it to the recipient 

image. If you don’t like the way the change affects the image, just remember what it 

is and fix it when you place the image. If you want to, after you have placed it, you 

can always go back to the original donor image in Bridge, right-click and choose 

Develop Settings>Clear Settings to remove the no longer necessary XMP file. 
 

If the donor image is a PSD, you will not need the benefit of Camera Raw, so just 

place it without special preparations.  
 

File types other than any of those listed here should be opened and saved in the TIF 

format so that you can run them through Camera Raw as described above. 
 

Before you start making changes to your original, be sure to “Save As” and give the 

image a new name so you don’t overwrite your original. As you proceed through 

the job, be sure to save every step of the way, just in case… 
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Placing an image- Raw or DNG files are best for this 

 A. In Bridge, click on the thumbnail for the image to be placed and hold 

 B. Drag the thumbnail to the Photoshop Icon in the Windows taskbar 

 C. Wait for the Photoshop window to appear 

D. When Photoshop appears, drag the thumbnail into the image area in 

Photoshop and release it 

E. If the donor image is a PSD, skip to step “F” below. If the donor image is a 

Raw or DNG, (or JPG, or TIF file processed as previously described), it will 

open in Camera Raw, do not make any changes to the image yet, just press 

“Enter” or click “OK” 

b. The image will then open in Photoshop in a Transform box 

c. Press “Enter” or double-click inside the Transform box 

d. In the Layers panel, double click the thumbnail icon for the layer 

containing the new image you just placed so that it will reopen in 

Camera Raw 

e. In Camera Raw, crop the image down to the essential area you want to 

place, usually the head, hair and shoulders of the head donor, and press 

“Enter” or click “OK” 

f. Proceed to step “5” below 

F. If the donor image is a PSD, it will appear in Photoshop inside a Transform 

box 

G. Press “Enter” or double-click inside the Transform box to finish placing 

the image 

a. In the Layers panel, double click the thumbnail icon for the layer 

containing the new image you just placed so that it will reopen in a new 

tab in Photoshop 

b. Crop the image down to the essential area you want to place, usually 

the head, hair and shoulders of the subject to be head swapped and Save 

it and close it (Ctrl+W then Y) 
 

5. With the newly cropped image in place in the middle of the picture, you will 

need to resize and move it. The Transform command will cover both of these bases 

at once 

A. Choose Edit>Transform>Scale or press Ctrl+T to open a Transform box 

around the donor layer 

B. Move the new head into place over the old one 

C. In the Layers panel, set the opacity of the new layer to somewhere between 

55 to 65%, whatever makes it easiest for you to see the two layers at once 

2 



D. Line up both right eyes or both left eyes, whichever is easier 

E. Alt Click in the center of the aligned eye to place the Transform crosshairs 

over the eye and make that eye the fulcrum or hub of rotation and resizing 

F. Move the cursor outside the Transform box until you see the double-ended 

curved arrow signifying rotation and rotate the image until all four eyes are on 

the same plane 

G. Holding down both the Shift and Alt keys, click on one corner of the 

Transform box and resize the image until all four eyes line up. This technique 

is done under the assumption that both the original and the donor heads are in 

very nearly the same position. If they are not, some adjustment may be 

necessary which will require a judgment call on your part, later 

H. Press “Enter” or double-click inside the Transform box to commit the 

Transform 

I. Reset the opacity for the new layer to 100% 

J. There may be further need to resize and move the donor head later 

 

6. With the donor head roughly in place, it’s time to put a layer mask on it  

A. If you are only using the face for the head swap, skip to step “B.” If you 

are using the whole head, hair and all… 

a. Using the Quick Selection tool, select the head and hair and anything 

else in the new layer that is to be included in the finished image 

b. Right-click inside the selection and choose “Refine Edge” 

� Pay close attention to the edges of hair 

� Very little feather is usually best 

� The Refine Radius tool is awesome 

� Set the output to “Layer Mask” 

� Click “OK” 

B. If all you need is the face, or part of the face… 

a. At the bottom of the Layers panel, Shift-click the “Add Layer Mask” 

icon (third from left) to add an all-Black layer mask 

b. You now have a Black mask over the new layer blocking it from view 

c. Using the Paint Brush tool, with the foreground color set to White, 

brush in the features you want to replace 

d. If you make a mistake, and bring back too much, press the “X” key to 

change the foreground color to Black and cover it back up; then press 

“X” again to return to White and continue until you have only the 

features showing that you want 
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Working with masks 

When you’re brushing in a mask, you can set the brush opacity lower to blend skin 

tones. Continue alternating between Black and White brushes and, if necessary, 

different opacity levels until you’re satisfied with the look of the image. Referring 

to Step 6, B above, for some people, it is easier to start with a White mask and 

brush out the features you don’t want. To do that, instead of Shift-clicking on the 

“Add Layer Mask” icon, just click on it and you will get a White mask on which to 

brush with Black to cover what you don’t want to show. 
 

7. Sometimes color, lighting and texture are not exactly perfect and may need some 

adjustment 

A. For color and lighting adjustments, just double-click on the thumbnail for 

the layer you want to adjust to open it as an independent item. If the new layer 

is from a Raw (or JPG, TIF, or DNG) file, this will reopen the image in 

Camera Raw where you can make the necessary adjustments. If the new layer 

is a PSD, it will open in a new tab in Photoshop and you can make the 

corrections and save and close it just like when you cropped it in step “4, G” 

B. It is not out of the ordinary for the new layer to look un-naturally smoother 

than the original. That is fixable… 

a. Make sure the new layer is selected in the Layers panel, and zoom in 

on the person who has been head swapped 

 b. In the Menu bar, choose Filter>Noise>Add Noise… 

c. If necessary, move the Add Noise dialog box aside so you can see the 

person’s face clearly 

d. Adjust the noise level until the texture of the two layers matches 

e. When you’re satisfied with the texture match, press “Enter” or click 

“OK” to close the Add Noise dialog box 

C. Sometimes, the new layer to is somewhat sharper than the original. 

a. Make sure the new layer is selected in the Layers panel, and zoom in 

on the person who has been head swapped 

 b. In the Menu bar, choose Filter>Blur>Gaussian Blur… 

c. If necessary, move the Gaussian Blur dialog box aside so you can see 

the person’s face clearly 

d. Adjust the blur level until the sharpness of the two layers matches 

e. When you’re satisfied with the sharpness match, press “Enter” or click 

“OK” to close the Gaussian Blur dialog box 

D. Since the new layer is a Smart Object, either filter, blur or noise, will be a 

Smart Filter which you can go back to and adjust should the need arise 
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E. If there is a color or tonal difference that is difficult to work out without 

seeing the whole image at once; or if you want to make a color correction to 

the entire image, you can use an adjustment layer to match up the tones 

1. With the layer you want to adjust selected in the Layers panel, click 

on the Adjustments tab. 

2. If the Adjustments tab is not visible, go to the Menu bar and choose 

Window>Adjustments 

3. Select the layer type for the adjustment you want to make and make 

the necessary corrections 

With adjustment layers, you can apply the settings you choose to all of the layers 

below the adjustment layer or, by clicking the “Clip to Layer” button at the bottom 

of the Adjustments panel (third from left) you can cause the adjustment to affect 

only the layer immediately below it. If there is a sweeping color balance issue like 

color temperature, the Color Balance Adjustment layer usually works well. For 

more subtle or precise corrections, especially to skin tones and hair color, the 

Hue/Saturation Adjustment layer usually works best. When using the 

Hue/Saturation Adjustment, click on the hand with the arrow through the finger 

(near top left) and you can then click on the specific area you want to adjust and it 

will work with that particular color range. If the area you want to adjust is too dark 

or too light, the Levels Adjustment layer allows for precise adjustment of shadows, 

midtones, and highlights. 
 

Whenever you create a new adjustment layer, the layer comes with a white mask. 

Using the Paint Brush tool, you can toggle between Black and White foreground 

colors to isolate a particular part of the layer for your adjustment to affect. If you 

select an area of a layer before creating an adjustment layer, the selected area will 

automatically be masked when the layer is created. 

 

8. The final touch-ups 
 

The last thing to do is the touch-up work. If the head donor is a good match, there 

may not be anything to clean up. Yay! Usually, there is a subtle difference between 

the position of the original head and the donor and a little of the original shows 

through or the background didn’t blend in well. If a background artifact shows or 

part of the original head (usually the hair) is a distraction, and it can’t be masked 

out, it is necessary to clone over those spots. 
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A. Make sure the original layer (or the top layer of the original image) is 

selected in the Layers panel 

B. At the bottom of the Layers panel, click on the “Create a New Layer” 

button 

C. This will place a new blank layer between the original image and the layer 

containing the new head 

D. Using either the Clone Stamp tool or the Healing Brush tool blend the area 

to cover or alter the parts you don’t want showing. 

 

9. Save your work. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Thomas Gartman 

P.O. Box 351 

Point Harbor, NC 27964 

252-573-8648 

info@gartmanbeachpix.com 
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